Predefined Constants
The DATE_*
constants are defined and offer standard
date representations, which can be used along with the date format functions
(like date() ).
Available returnFormat for
date_sunrise() and
date_sunset()
Warning
These constants are deprecated as of PHP 8.4.0.
The corresponding date_sunrise() and
date_sunset() functions are deprecated as of PHP 8.1.0.
SUNFUNCS_RET_TIMESTAMP
(int )
Timestamp
SUNFUNCS_RET_STRING
(int )
Hours:minutes (example: 08:02)
SUNFUNCS_RET_DOUBLE
(int )
Hours as floating point number (example 8.75)
DATE_* constants
DATE_ATOM
(string )
Atom (example: 2005-08-15T15:52:01+00:00); compatible with ISO-8601, RFC 3339, and XML Schema
DATE_COOKIE
(string )
HTTP Cookies (example: Monday, 15-Aug-2005 15:52:01 UTC)
DATE_ISO8601
(string )
ISO-8601-like (example: 2005-08-15T15:52:01+0000)
Note :
This format is not compatible with ISO-8601, but is left this way for
backward compatibility reasons. Use
DATE_ISO8601_EXPANDED ,
DATE_ATOM for compatibility with ISO-8601
instead (ref ISO8601:2004 section 4.3.3 clause d).
DATE_ISO8601_EXPANDED
(string )
ISO-8601 Expanded (example: +10191-07-26T08:59:52+01:00)
Note :
This format allows for year ranges outside of ISO-8601's normal range
of 0000-9999 by always
including a sign character. It also ensures that the timezone part
(+01:00) is compatible with ISO-8601.
DATE_RFC822
(string )
RFC 822 (example: Mon, 15 Aug 05 15:52:01 +0000)
DATE_RFC850
(string )
RFC 850 (example: Monday, 15-Aug-05 15:52:01 UTC)
DATE_RFC1036
(string )
RFC 1036 (example: Mon, 15 Aug 05 15:52:01 +0000)
DATE_RFC1123
(string )
RFC 1123 (example: Mon, 15 Aug 2005 15:52:01 +0000)
DATE_RFC7231
(string )
RFC 7231 (as of PHP 7.0.19 and 7.1.5)
(example: Sat, 30 Apr 2016 17:52:13 GMT)
DATE_RFC2822
(string )
RFC 2822 (example: Mon, 15 Aug 2005 15:52:01 +0000)
DATE_RFC3339
(string )
Same as DATE_ATOM .
DATE_RFC3339_EXTENDED
(string )
RFC 3339 EXTENDED format
(example: 2005-08-15T15:52:01.000+00:00)
RSS (example: Mon, 15 Aug 2005 15:52:01 +0000).
Alias of DATE_RFC1123 .
DATE_W3C
(string )
World Wide Web Consortium (example: 2005-08-15T15:52:01+00:00).
Alias of DATE_RFC3339 .